hypweb.net
XOOPSマニア  最新情報のRSS(サイト全体)
[ 自宅サーバーWebRing |ID=54 前後5表示乱移動サイト一覧 ]

TOP » UsersWiki » nao-pon » blog » 2005-11-07

PHP を 4.4.2-dev にしてみようかと anchor.png

なんとなく、PHP を めっちゃ最新版の 4.4.2-dev にしてみようかと思って、PHP Snapshots から一番新しいものを取得して、入れ替えてみた。

PHP自体に問題はなく、無事に完了してこのサイトの動作も問題はなかったのですが、どうやら eAccelerator が対応していないらしく、再コンパイルして試してみても eAccelerator が有効になりませんでした。

アクセレーターなしでは、過負荷時にかなりきついので、泣く泣く元に戻しました。

あ〜。無駄な1時間を過ごしてしまった。 ;( もう寝よっと。


  • こちらではPHP-4.4.1 にしましたが、eAccelerator は使えていますよ。 -- matio 2005-11-07 (月) 04:49:31
  • eAccelerator公式サイトから引っ張って、解凍してphpize して# ./configure --enable-eaccelerator=shared --with-php-config=/usr/local/bin/php-confi g(環境により違うかも) -- 通りすがりさん 2005-11-16 (水) 12:20:41
  • makeして makeinstallするとextensionDirにeaccelerator.soファイルが作成できますよ。その後php.iniの設定で動きます?(と思います。)このサイト大好きです。色々パクらせて貰っています。 :D 生意気に書き込んでしまいました。 -- 通りすがりさん 2005-11-16 (水) 12:24:03
  • PHP4.3系と5系のあのパッチだけでは不安?です。PHP4.4.2の方が少し安心?MySQLも5系でガンガン動いてます。上↑2スレ書いた通りすがりでした ;) -- 通りすがりさん 2005-11-16 (水) 12:27:26
  • ウチは横着してeAcceleratorこっから入手してます・・https://hpwb.net/5gXJLZ (siokara.que.jp) -- 通りすがりさん 2005-12-08 (木) 14:52:22
  • Vine の apt-upgrade で PHP が 4.4.1 になったら、やはりeAcceleratorが動かん。
export PHP_PREFIX="/usr"
$PHP_PREFIX/bin/phpize
./configure --enable-eaccelerator=shared --with-php-config=$PHP_PREFIX/bin/php-config
make
make install

ってしたんだけどなぁ。eAccelerator 0.9.4-rc1にしてもだめ。 ;(

しょうがないので、PHP 4.3.11 + Globalパッチ に戻しました。 -- nao-pon&trip("iq8llSWq9g"); 2005-12-14 (水) 10:34:48




Front page   Freeze Diff Backup Copy Rename ReloadPrint View   New Page Page list Search Recent changes   Help   RSS of recent changes (RSS 1.0) RSS of recent changes (RSS 2.0) RSS of recent changes (RSS Atom) Powered by xpWiki
Counter: 53, today: 1, yesterday: 0
Princeps date: 2006-09-12 (Tue) 22:16:38
Last-modified: 2006-09-12 (Tue) 22:16:38 (JST) (5086d) by nao-pon
このページのTopへ
メインメニュー
ログイン

ユーザー名:


パスワード:





パスワード紛失  |新規登録
オンライン状況
50 人のユーザが現在オンラインです。 (2 人のユーザが UsersWiki を参照しています。)

登録ユーザ: 0
ゲスト: 50

もっと...