hypweb.net
XOOPSマニア  最新情報のRSS(サイト全体)
[ 自宅サーバーWebRing |ID=54 前後5表示乱移動サイト一覧 ]

17年11月18日(Sat) 15時39分
TOP » フォーラム » XOOPS » X-elFinder » vendor アップデート

vendor アップデート


投稿ツリー


前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2017-7-10 22:45
kf-user 

お世話になっております。
xelfinder 2.19をインストールし、vendorアップデート「PHP CLI Command」で
アップデートしたところ、

Your version of PHP, 5.4.XX, is affected by CVE-2013-6420 and cannot safely perform certificate validation,
we strongly suggest you upgrade.
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

上記エラーとなってしまいました。
現在のままのPHPのバージョンでアップデートしたい場合は、どうしたらよいでしょうか。
教えていただけたらと思います。

投票数:0 平均点:0.00
返信する
前の投稿 - 次の投稿 | 親投稿 - 子投稿.1 | 投稿日時 2017-7-11 14:21
nao-pon  Webmaster 居住地: 愛知県  投稿数: 5755

kf-user さん、こんにちは。

Dropbox 用のライブラリ kunalvarma05/dropbox-php-sdk が PHP 5.5 以上を要求するのでエラーになってしまいますね。

とりあえず、PHP 5.4 系の場合は kunalvarma05/dropbox-php-sdk を除外するような対策をしてみました。

このファイルを差し替えて試してみてください。

投票数:0 平均点:0.00
返信する
前の投稿 - 次の投稿 | 親投稿 - 子投稿なし | 投稿日時 2017-7-11 22:13
kf-user  

お世話になっております。kf-userです。
いただきましたファイルに差し変えて実行したところ、
無事にアップデートを完了することができました。
早急なご対応に、大変感謝しております。
ありがとうございました。

投票数:0 平均点:0.00
返信する

このトピックに投稿する

題名
ゲスト名
投稿本文

  条件検索へ

このページのTopへ
ログイン
ユーザ名:

パスワード:

オートログイン

Basic 認証

新規登録 | パスワード紛失



メインメニュー
ブックマーク
オンサイトブックマークは
ログインするとご利用になれます
[ログインする]
サイト内 Wiki
☆ 検索 ☆



高度な検索(サイト内)
FireFox検索プラグイン
オンライン状況
合計 57 人がオンライン中 :-)
(フォーラム : 2 人)

登録ユーザ: 0 & ゲスト: 57

もっと...
サイト情報
管理人

nao-pon
 

登録ユーザ数: 4477


Web Services by Yahoo! JAPAN
楽天ウェブサービスセンター
Amazon.co.jpアソシエイト
現在ページのQRコード
現在ページのQRコード
[携帯対応]
参照元情報
参照なし