hypweb.net
XOOPSマニア  最新情報のRSS(サイト全体)
[ 自宅サーバーWebRing |ID=54 前後5表示乱移動サイト一覧 ]

19年4月20日(Sat) 6時33分
TOP » フォーラム » XOOPS » xpWiki » autolink.datが正しく生成されなくなりました
Top  >  XOOPS  >  xpWiki ( Next topic )

autolink.datが正しく生成されなくなりました


Posts tree


Previous post - Next post | Parent - Children.1 | Posted on 2018-10-1 16:35
Blue 

nao-pon さん、こんにちは。
いつもお世話になっております。

XpWikiを使って、仕事用の手引を作っているのですが、最近になってオートリンクが変になってしまいました。
初めは、新しく作成したページへのオートリンクができないようだったので、更新したりキャッシュを削除したりしているうちに全くオートリンクが効かない状態になってしまいました。
いろいろと設定をいじくり回してみたのですが、どうにも解決の糸口が見えてきません。

最近追加したページに不正な文字が混入した等の理由でこういうことが起こり得るものでしょうか?
何か原因につながる手がかりを得る方法がありましたらご教示いただけないでしょうか。
よろしくお願いいたします。

現在の autolink.datは、以下のとおりです。(オートリンク有効ページ名バイト数4)
FrontPage
(?!)

a:0:{}
a:0:{}

オートリンク有効ページ名バイト数を30にするとこうなりました。
(?:[A-Z][a-z]+){2,}(?![a-zA-Z0-9_])
(?:[A-Z][a-z]+){2,}(?![a-zA-Z0-9_])

a:0:{}
a:0:{}

Votes:0 Average:0.00
Reply
Previous post - Next post | Parent - No child | Posted on 2018-10-26 23:21
ゲスト 

nao-pon さん、こんばんは。
自己レスです。

あらためてこちらのサイトの過去ログを検索していて、5年程前にオートリンクの仕様について nao-pon さんからご教示いただいていたことに気づきました。
閲覧権限を設定したページにはオートリンクは張られないのでしたね。
先日、思うところがあって全てのページをゲストユーザーが閲覧できないように設定したところでした。
そのせいでオートリンクが全く機能しないように見えていました。

閲覧権限の制限を外したら、何事もなかったようにオートリンクが機能しました。
お騒がせして申し訳ありませんでした。

Votes:0 Average:0.00
Reply

Post into this topic

Subject
guestname
Body

  Advanced search

このフォーラムのトピック一覧
このページのTopへ
ログイン
ユーザ名:

パスワード:

オートログイン

Basic 認証

Register now! | Lost Password?



メインメニュー
ブックマーク
Please log in to use it.
[Login]
サイト内 Wiki
☆ 検索 ☆



高度な検索(サイト内)
FireFox検索プラグイン
オンライン状況
合計 54 人がオンライン中 :-)
(フォーラム : 5 人)

登録ユーザ: 0 & ゲスト: 54

もっと...
サイト情報
管理人

nao-pon
 

登録ユーザ数: 4604


Web Services by Yahoo! JAPAN
楽天ウェブサービスセンター
Amazon.co.jpアソシエイト
現在ページのQRコード
現在ページのQRコード
[携帯対応]
参照元情報
No trackback