Back to page

− Links

 Print 

Source of 独自ビルドの Tasmota を 12.1.1 へ :: XOOPS マニア

Source of UsersWiki:nao-pon/blog/2022-08-26

« Prev[3]  
#navi
RIGHT:&rsslink(../);
#boxdate

* 独自ビルドの Tasmota を 12.1.1 へ [#fb442d40]
RIGHT:&tag(ESP8266,家IoT,HomeAssistant,Tasmota,ビルド);

&ref(Screenshot_20220826-195833.png,mw:480,mh:360,right,around);

エアコンのWiFi化に Tasmota をカスタマイズした独自ビルドを使っているけど、Tasmota 12.1.1 がリリースされたので、アップデートした。

まずは、ブログに書いていなかったけど Tasmota 11.0.0.1 から 12.0.2.3 へアップデートについて

** Tasmota 11.0.0.1 から 12.0.2.3 へアップデート [#nb1ab8fd]

ちょっと前のことだけど...
今回は少し躓きました。[[いつもの通り>../2021-06-20]]にはいかなかった。

まずは、いつも通り

#pre(){{
git checkout master
git pull
git checkout mitsu_pana_custom
git diff HEAD^1 > _diff1.txt
git rebase master
git diff HEAD^1 > _diff2.txt
}}
で、_diff1.txt と _diff2.txt を比較して、問題なくカスタマイズ分が反映されているか確認する。

 diff _diff1.txt _diff2.txt > _diff3.txt

Tasmota は marge で

#pre(){{
git checkout development
git pull
git checkout irremote_full_custom
git marge master
}}

Tasmota の pio run でエラー

とりあえず platformio upgrade -> パーミッションエラー

#pre(){{
su
platformio upgrade
}}

まだエラー、よく見たらディレクトリ構成が変わっていた!
例えば tasmota/xdrv_05_irremote_full.ino -> tasmota/tasmota_xdrv_driver/xdrv_05_irremote_full.ino

- xdrv_05_irremote_full_custom.ino を tasmota/tasmota_xdrv_driver へ
- xsns_31_ccs811_v2_10sec.ino, xsns_31_ccs811_v2_60sec.ino を tasmota/tasmota_xsns_sensor へ

これで OK だった。

** Tasmota 12.0.2.3 から 12.1.1 へアップデート [#ba788c42]

これまた、いつも通りに。

#pre(){{
git checkout master
git pull
git checkout mitsu_pana_custom
git diff HEAD^1 > _diff1.txt
git rebase master
git diff HEAD^1 > _diff2.txt
}}

Tasmota は、今回から development ではなく、リリースバージョンをつかうことにした。まあ、深い意味はなく、なんとなく。

#pre(){{
git checkout development
git pull
git checkout irremote_full_custom
git merge v12.1.1
}}
で

 pio run

...あれ?なにか変... environment がデフォルトになってる模様。

 pio run -e ir_jema_bridge

とかしてみると、ビルドがエラーで止まってしまう。

とりあえず platformio をアップデート

 su
 platformio upgrade

それでもエラー。なんか IRremoteESP8266 でバグってるみたいだったので、IRremoteESP8266 のほうは、元に戻してみた。

 git reset --hard 02b5833aaa3e92e386d2f9ec82db122c90f33e5a

こちらは、これで問題なくなった模様だけど、また新たなエラー。

"header:ihx.h" が見つからないとかなんとか。

 platformio lib search "header:ihx.h"

としてみたら、「ナニソレ?シラナイナ」とかの返事。

ググってみたところ、[[Sonoff-Tasmota:https://github.com/erocm123/Sonoff-Tasmota/blob/master/lib/C2Programmer-1.0.0/src/ihx.h]] のものらしい。

あ!わかった!あれだ!

Zigbee の 有線 LAN ブリッジを導入した時に、Tasmota を [[vahempio/Tasmota-for-eWeLink:https://github.com/vahempio/Tasmota-for-eWeLink]] を利用して自分でビルドしたのだけど、その時に platformio_override.ini と tasmota/user_config_override.h が書き換わっていて、それが原因だった。

それぞれを以下の内容で保存し直して、今度は問題なくビルドが完了した。

- [[platformio_override_sample_hyp.ini:https://github.com/nao-pon/Tasmota/blob/irremote_full_custom/platformio_override_sample_hyp.ini]]
- [[user_config_override_sample_hyp.h:https://github.com/nao-pon/Tasmota/blob/irremote_full_custom/tasmota/user_config_override_sample_hyp.h]]

目的が違うものを同じディレクトリで使用するのはよくないなぁ。混ぜるな危険!

今度からは別のディレクトリで行おう。

RIGHT:&font(90%){&page_comments;};
#navi

« Prev[3]