Back to page

− Links

 Print 

xpWiki 5.02.28 から PHP 5.3 未満では動作しなくなります :: XOOPS マニア

xpwiki:xpWiki開発日記/2017-10-11


Wed 11 Oct 2017
 

xpWiki[4] 5.02.28 から PHP 5.3 未満では動作しなくなります anchor.png[5] Edit [6]

module_icon.png Tag: アナウンス[7]

PHP 7.2 対応のため、xpWiki[4] は次回のバージョン 5.02.28 から PHP 5.3 未満では動作しなくなります。

その理由の一つとして `create_function` 関数が PHP 7.2 から非奨励になることがあげられます。`create_function` 関数の代わりに PHP の無名関数構文を使用しますが、これが PHP 5.3 未満では動作しないためです。

未だ PHP 5.3 未満の環境の方はほぼいないと思いますが、ご承知おきください。

Page Top

一行コメント anchor.png[9] Edit [10]




Last-modified: 2017-10-11 (Wed) 10:16:08 (JST) (1441d) by nao-pon